$re = '/\((?=\d)/m';
$str = 'abc (123
abc (def) (123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);