$re = '/^\d+\s*/m';
$str = 'PO BOX 850
555 Happy Lane';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;