import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<Timestamp>\\b(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\\b[\\s+\\w+]+[\\w+:?]+)\\s+(?<SourceIP>[\\d+\\.?]+)\\s+(?P<EventID>%PIX-6-\\d+):\\s+(?P<EventMessage>Teardown UDP connection\\s+\\d+) for (?P<OutsideIP>.*?) to (?P<InternalIP>.*?)\\s+duration\\s+(?P<Duration>.*)\\s+bytes(?P<Bytes>\\s+\\d+)";
final String string = "Jul 25 23:56:11 210.56.128.109 %PIX-6-302016: Teardown UDP connection 71944828 for Outside:192.168.20.21/22920 to Internal:osaka/137 duration 0:02:09 bytes 500";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}