const regex = /(?<=(\"(value411|value412)\"\:))[\"\w+]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(\\"(value411|value412)\\"\\:))[\\"\\w+]+', 'gm')
const str = `{"value1":5.0,"value2":2.5,"value3":"2019-10-24T15:26:00.000Z","modifier":[],"value4":{"value41":{"value411":5,"value412":"hey"}}}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}