$re = '/\s+[:;|]\s+[a-zA-Z0-9-]+/ui';
$str = ' :Hello123
: Hello123
: Hello 123
: Hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);