package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)^ # début de chaîne
(?<sexe>[12]) # 1 ou 2 pour le sexe
(?<naissance>[0-9]{2}(?:0[1-9]|1[0-2])) # année et mois de naissance (aamm)
(?<departement>2[AB]|[0-9]{2}) # le département
(?<postal_code>[0-9]{3}) # suite du code postal sur trois chiffres
(?<numserie>[0-9]{3}) # numéro de série sur trois chiffres
(?<controle>[0-9]{2})? # numéro de contrôle (facultatif)
$ # fin de chaîne`)
var str = `181125935505970`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}