$re = '/(^|\s)(https|ftp|file):\/\/[^\/]+\/\w+((\?[^&\s]+)?&|(&[^\?\s]+)?\?)($|\s)/m';
$str = 'https://helloworld.io/foobar?
https://helloworld.io/foobar&
https://helloworld.io/foo&bar?
https://helloworld.io/foo?bar&
https://helloworld.io/foo&bar?baz?bum&
https://helloworld.io/foo?bar&baz&bum?
https://helloworld.io/foobar
https://helloworld.io/foo&bar
https://helloworld.io/foo?bar
https://helloworld.io/foo?bar?
https://helloworld.io/foo&bar&
https://helloworld.io/foo&bar?baz
https://helloworld.io/foo?bar?baz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);