package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bc\+\+\B`)
var str = `I am using c++ programming
I am usingc++ programming
I am using c++programming
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}