$re = '/(=\s\W\w+\W|=\s\d+)/m';
$str = 'SELECT * FROM Table1 WHERE Column1 = 1
SELECT * FROM Table1 WHERE Column1 = \'abc\'
SELECT * FROM Table1 WHERE (Column1 = \'abc\' OR Column2 = 1)
SELECT * FROM Table1 WHERE (Column1 = \'abc\' AND Column2 = 1) OR Column2 = \'zxy\'
SELECT * FROM Table1 WHERE (Column1 = \'abc\' AND Column2 = 1) OR Column2 = \'zxy\' AND
Column3 = 2
SELECT * FROM Table1 WHERE Column1 = 1 AND Column2 = 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);