re = /[^\/]+(?=\?st)/m
str = ' https://some_website.com/folder/file_name.mkv?st=OyvPiQZL8HmbCkapHo-tLg&e=1571543844'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end