$re = '/^def [triangles=(1,SNAKE)]{27}:print[]SNAKE(--:>or[]{48}$/';
$str = 'def S(N,A=1,K=1,E=list,r=range):print(E(r(A,A+N)[::K]))or(A>N*N-N)or(((S(N,A+N,-K))))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);