import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$([a-z0-9-]+):\\s+(.[^;]{3,6}\\s*(!default)?);";
final String string = "\n"
+ "$color-white: #ffffff !default;\n"
+ "$color-black: #000000 !default;\n\n"
+ "$color-gray-lightest: #f5f5f5 !default;\n"
+ "$color-gray-lighter: #ededed !default;\n"
+ "$color-gray-light: #e5e3e3 !default;\n"
+ "$color-gray-mid: #d1d0d0 !default;\n"
+ "$color-gray-dark: #a3a2a2 !default;\n"
+ "$color-gray-darker: #636363 !default;\n\n"
+ "$color-error: #ff0000;\n"
+ "$color-success: #2cfba5;\n\n"
+ "$color-brand-group-1-lighter: #f8d9dd !default;\n"
+ "$color-brand-group-1-light: #de9193 !default;\n"
+ "$color-brand-group-1: #be2428 !default;\n\n"
+ "$color-brand-group-2-lightest: #f3f3f3 !default;\n"
+ "$color-brand-group-2-lighter: #8e97ae !default;\n"
+ "$color-brand-group-2-light: #77839d !default;\n"
+ "$color-brand-group-2: #1d305d !default;\n"
+ "$color-brand-group-2-dark: #0a1c42 !default;\n\n"
+ "$color-brand-group-3-light: #84d7b6 !default;\n"
+ "$color-brand-group-3: #0faf6d !default;\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}