import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?P<protocol>.+)://)?(?:(?P<sub>.+)\\.)?(?P<domain>.+)\\.(?P<tld>[a-zA-Z]+)(?P<path>/(?:(?:.*?)(?:(?=\\?)?))?)?(?P<query>\\?.+?)?$";
final String string = "google.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}