re = /(?<=\[identifier])\w+=[^;]*(?:;\w+=[^;]*)*/m
str = 'irrelevant part[identifier]key1=val1;key2=val2;key3=val3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end