$re = '~^(?:((\/subdirectory\b)(?!-)(\/)?))(?<requestedPath>.*)?$~';
$str = '/subdirectory/?this=that&tjat=this&apply-code=test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);