re = /./
str = '!"#$%&\'( )*+,-./
0123456789:;<=>?
@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_
`abcdefghijklmnopqrstuvwxy z{|}~'
# Print the match result
str.match(re) do |match|
puts match.to_s
end