$re = '/^(?!(?:[01]*0)?(?:1{2})+(?:0|$))[01]+$/m';
$str = '1001110111
10110111
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);