import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((19\\d\\d|20\\d\\d)-(0\\d|1[0-2])-([0-2]\\d|30|31))T((\\d{2}):(\\d{2}):(\\d{2}))(?:\\.(\\d{3,6}))?(?:((?:([+-])(?:(0\\d|1[012]))):?([0-5]\\d))|Z?)";
final String string = "2008\n"
+ "2004-04-14\n"
+ "1997-01-27T18:57Z\n"
+ "2010-14-21T08:12:17.243+07:00\n\n"
+ "2010-12-21T08:12:17.243Z\n"
+ "2010-12-21T08:12:17.243\n"
+ "2010-11-21T08:12:17.243+07:00\n"
+ "2010-11-01T08:12:17.243+07:00\n"
+ "2010-12-11T08:12:17.243+0700\n"
+ "2010-01-21T08:12:17.243+07:00\n"
+ "2010-11-31T08:12:17.243+07:00\n"
+ "2010-14-21T08:12:17.243-37:00\n"
+ "2010-11-32T08:12:17.243+07:00\n"
+ "2010-14-21T08:12:17.243+0000\n"
+ "2010-14-21T08:12:17.243+1000\n"
+ "2010-11-21T08:12:17.243+0060\n"
+ "2010-14-21T08:12:17.243+1000\n"
+ "2010-14-21T08:12:17.243+1000\n"
+ "Non-Matches \n"
+ "3:00, 2/28/2003\n"
+ "2004-07-12 14:25:59\n"
+ "1900-01-01 00:00:00\n"
+ "9999-12-31 23:59:59\n"
+ "Non-Matches \n"
+ "04-07-12 14:25:59\n"
+ "20004-07-12 14:25\n"
+ "2004/07/12 14:25:59";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}