$re = '/(?<!STI|VÄ)G$/m';
$str = 'Q5_1.TEXT
Q5_1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);