re = /[a-z|0-9]? ?(\\|\+|- ?[^a-z|^0-9]|\^|\*|\/|\(|\)){1} ?/m
str = '+ + a |a| +'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end