import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?:[^|\\r\\n]*\\|){10}[^|\\r\\n]*\\K\\||(?!^)\\G[^|\\r\\n]*\\K\\|)(?=.*(?:\\|[^|\\r\\n]*){2}$)";
final String string = "A1|A2|A3|A4|A5|A6|A7|A8|A9|A10|A11|A12|A13|A14|A15|A16|AA\n"
+ "B1|B2|B3|B4|B5|B6|B7|B8|B9|B10|B11|B12|B13|B14|B15|AA\n"
+ "C1|C2|C3|C4|C5|C6|C7|C8|C9|C10|C11|C12|C13|C14|AA\n"
+ "D1|D2|D3|D4|D5|D6|D7|D8|D9|D10|D11|D12|D13|AA\n"
+ "E1|E2|E3|E4|E5|E6|E7|E8|E9|E10|E11|E12|AA\n";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}