package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\"[\w\s]+\")`)
var str = `"Foo Bar" "Another Value" something else "Suganthan"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}