re = /^(?!417500.{10}|4026.{12}|4405.{12}|4508.{12}|4844.{12}|4913.{12}|4917.{12})(?=4.{12}|4.{15}).*/m
str = '4123456789452
4767656752657256
4026678267543216
4175001234567865
4278908765432
4027236512341234
4844999999999999
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end