using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"readme\.md";
string input = @"README.MD
readme.md
ReadMe.md";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}