const regex = /"resource_id": "[^"]*?(?<last_word>\w+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"resource_id": "[^"]*?(?<last_word>\\w+)"', 'gm')
const str = `{"resource_id": "/subscriptions/85bbb6fe-yyyy-xxx-81a6-806aaa0ca/resourceGroups/vg-test/providers/Microsoft.Web/sites/TestAPI", "metric_name": "FSUsage", "timeStamp": "2025-12-14T14:48:00Z", "subscription_id": "85bbb6fe-yyyy-xxx-81a6-806aaa0ca", "unit": "Bytes", "namespace": "microsoft.web/sites", "resource_group": "vg-test", "average": 0}
{"resource_id": "/subscriptions/85bbb6fe-yyyy-xxx-81a6-806aaa0ca/resourceGroups/vg-test/providers/Microsoft.Sql/servers/test-sql-01/databases/Test_Prod", "metric_name": "allocated_storage", "timeStamp": "2025-12-14T14:57:00Z", "subscription_id": "85bbb6fe-yyyy-xxx-81a6-806aaa0ca", "unit": "Bytes", "namespace": "microsoft.sql/databases", "resource_group": "vg-test", "average": 855016}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}