re = /^(([0-9]([ ]|$)|([1-5][0-9]([ ]|$))|(6[0-3]([ ]|$))){1,4})$/m
str = '63 0 0
9 9 490 0
8 5 0
0 0 0 0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end