$re = '/^([^_].*?)\s*=\s*(.*?)/m';
$str = '__$id0 = "lala"
$id0 = "lala"
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);