re = /\d{2}\.\d/
str = 'Die Temperaturen betrugen am Montag 22.5 °C und am Dienstag 24.5 °C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end