re = /'([^']*)'|[^\s']+/m
str = 'This is some testing dbo.GetPersonData(this_.PersonId,\'Date contract recieved from the client\') cs.dbo.Person \'this is test\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end