$re = '/map=([^\&]*)(&|$)/';
$str = 'param1=blah¶m2=blahblah¶m3=blahetc&map=/usr/bin/blah.map';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);