$re = '/^(([a-zA-Z]{2}[0-9]{16})|([0-9]{12}))$/';
$str = 'HS1245784512447878';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);