$re = '/(?<=\$)([^$]*)(?=\$)/m';
$str = 'gaag a gaga $fafaga$afa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);