$re = '/^(\d|\w)+$/';
$str = 'asd3223sdf23423asdas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);