use strict;
my $str = 'kol1,kol2,"kol3,kol3a",hhhh,"bb,bbb",kkff,ddd,"lll"
';
my $regex = qr/(,)(?=[^"]*"(?:[^"\r\n]*"[^"]*")*[^"\r\n]*$)/p;
my $subst = '{comma}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";