# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n(?=Layer)"
test_str = ("Layer:defaultRenderLayer\n"
"Line 1 text goes here\n"
"Line 2 text goes here\n"
"Line 3 text goes here\n"
"Layer:diffuse\n"
"Line 1 text goes here\n"
"Line 2 text goes here\n"
"Line 3 text goes here\n"
"Line 4 text goes here\n"
"Line 5 text goes here\n"
"Layer:outline\n"
"Line 1 text goes here\n"
"Line 2 text goes here")
subst = "\\n\\n-------------------------\\n\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.