$re = '/RequestReadTimeout\sheader=(?:\d+)?-?(\d+).*/m';
$str = 'RequestReadTimeout header=3333-40,MinRate=XXX body=XXX
RequestReadTimeout header=40 body=XXX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);