$re = '/(?<!#)focus|focus(?!#)/m';
$str = 'focus;focus#focus#focus focus';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);