re = /\/.+mpg/
str = 'http://71.85.85.100/http_client_file_transfer/epixhd.com!XPMV0000000000313234.mpg'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result