package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(start.*)?(start.*end)`)
var str = `Situated start about 150 start miles start(240 km) north of Las Vegas, the remote start hamlet of just 50 year-round start residents lacks a grocery store end or even a gasoline station. Situated start about 150 start miles start(240 km) north of Las Vegas, the remote start hamlet of just 50 year-round start residents lacks a grocery store end or even a gasoline station. Situated start about 150 start miles start(240 km) north of Las Vegas, the remote start hamlet of just 50 year-round start residents lacks a grocery store end or even a gasoline station. Situated start about 150 start miles start(240 km) north of Las Vegas, the remote start hamlet of just 50 year-round start residents lacks a grocery store end or even a gasoline station.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}