package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[:,\s]\s*url\s*\(\s*(?:'(\S*?)'|"(\S*?)"|((?:\\\s|\\\)|\\\"|\\\'|\S)*?))\s*\)`)
var str = `.ac-gn-link-apple{background-repeat:no-repeat;background-size:20px 44px;background-image:url("../images/ac-globalnav/globalnav/apple/image_large.svg");background-position:center center;width:20px}#ac-globalnav.no-svg .ac-gn-link-apple{background-image:url("http://images.apple.com/ac/globalnav/2.0/en_US/images/ac-globalnav/globalnav/apple/image_large.png")}@media only screen and (max-width: 767px){#ac-globalnav .ac-gn-link-apple{background-size:21px 48px;background-image:url("../images/ac-globalnav/globalnav/apple/image_small.svg")}#ac-globalnav.no-svg .ac-gn-link-apple{background-image:url("http://images.apple.com/ac/globalnav/2.0/en_US/images/ac-globalnav/globalnav/apple/image_small.png")}}.ac-gn-current-apple #ac-globalnav .ac-gn-link-apple{opacity:0.65;-ms-filter:'progid:DXImageTransform.Microsoft.Alpha(Opacity=$ieopacity)';filter:alpha(opacity=65)}#ac-globalnav .ac-gn-link-mac{background-repeat:no-repeat;background-size:31px 44px;background-image:url("../images/ac-globalnav/globalnav/links/mac/image_large.svg");background-position:center center;background-origin:content-box;background-size:cover;width:1.72222em;max-width:52.7px}#ac-globalnav.no-svg .ac-gn-link-mac{background-image:url("http://images.apple.com/ac/globalnav/2.0/en_US/images/ac-globalnav/globalnav/links/mac/image_large.png")}@media only screen and (max-width: 767px){#ac-globalnav .ac-gn-link-mac{background-size:37px 48px;background-image:url("../images/ac-globalnav/globalnav/links/mac/image_small.svg")}#ac-globalnav.no-svg .ac-gn-link-mac{background-image:url("http://images.apple.com/ac/globalnav/2.0/en_US/images/ac-globalnav/globalnav/links/mac/image_small.png")}}.ac-gn-current-mac #ac-globalnav .ac-gn-link-mac{opacity:0.65;-ms-filter:'progid:DXImageTransform.Microsoft.Alpha(Opacity=$ieopacity)';filter:alpha(opacity=65)}#ac-globalnav .ac-gn-link-ipad{background-repeat:no-repeat;background-size:30px 44px;background-image:url("../images/ac-globalnav/globalnav/links/ipad/image_large.svg");background-position:center center;background-origin:content-box;background-size:cover;width:1.66667em;max-width:51px}#ac-globalnav.no-svg .ac-gn-link-ipad{background-image:url("http://images.apple.com/ac/globalnav/2.0/en_US/images/ac-globalnav/globalnav/links/ipad/image_large.png")}@media only screen and (max-width: 767px){#ac-globalnav .ac-gn-link-ipad{background-size:35px 48px;background-image:url("../images/ac-globalnav/globalnav/links/ipad/image_small.svg")}#ac-globalnav.no-svg .ac-gn-link-ipad{background-image:url("http://images.apple.com/ac/globalnav/2.0/en_US/images/ac-globalnav/globalnav/links/ipad/image_small.png")}}.ac-gn-current-ipad #ac-globalnav .ac-gn-link-ipad{opacity:0.65;-ms-filter:'progid:DXImageTransform.Microsoft.Alpha(Opacity=$ieopacity)';filter:alpha(opacit...
:url(asdawdw)
: url(asdawdw)
: url (asdawdw)
: url ( asdawdw)
: url ( asdawdw )
: url ( asdawdw )
:url('asdawdw')
: url('asdawdw')
: url ('asdawdw')
: url ( 'asdawdw')
: url ( 'asdawdw' )
: url ( 'asdawdw' )
:url("asdawdw")
: url("asdawdw")
: url ("asdawdw")
: url ( "asdawdw")
: url ( "asdawdw" )
: url ( "asdawdw" )
:url(asda\)wdw)
:url(asda\))wdw) <- should terminate early, due to unescape paren
:url(asda\ wdw)
:url(asda\ wdw) <- unescape space, invalid
:url(asda\"wdw)
:url(asda\" wdw) <- unescape space, invalid
:url(asda\'wdw)
:url(asda\')wdw) <- should terminate early, due to unescape paren
: url ( "asda\"wdw")
: url ( 'asda\"wdw')
: url ( 'asda\)))wdw')
: url ( 'asda\"))wdw')
: url ( asda\"))wdw)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}