const regex = /(\d+[.,]0+)(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+[.,]0+)(?!\\d)', 'gm')
const str = `Test (2.00001) Test (2.000) Test 2.1 Test (2,0001) Test 2,000 Test 2,1000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}