// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[]^C]\w$|\w.\)|w[[+^]|\?[^w$]*\$$").unwrap();
let string = "PPCG
^P
^[P^]P
[^?][PG]$
(?<!\\\\..)(?!]).$
^[\\w^]*$|!|]P|G]\\$$
!|[^?]P(CG|G..)?$
[^])]\\$|^\\^?P|P.\\].$
([.$?]|G\\])\\$$|^\\^?P|\\]P$
([P.$?]\\$|[]^]P|G\\]\\$|CG)$
!|((G.|P|\\.)\\$|[^?]P|CG)$
^[(!P]|G..$|]..\\||[^?]P$
^.{3,23}[.-~]..\\$$|[^P?][PG]$
^..(.[!G)(3w^]|.{7}$|$)|\\$\\?
\\.\\)|P[.$?]|w\\^|^[^|C\\\\]*$|^P
^..(.[!)3G^w]|$)|\\^.{7}$|G\\)
\\?[^w$]*\\$$|[]^C]\\w+$|w\\^|\\|..\\)
\\w.\\)|\\?[^-$]*\\$$|[]^C]\\w$|w[+^]
[PPCG]
^[P\\^]
[^\\]]$
^\\^?P
[^?][PG]$|<|PG
^[^\\\\|]*(\\\\\\\\)+[^\\\\|]*[^\\]]$
^(.{,4}|.{9}|.{16,19}|.{5}P)$
^[^?]*[PG]$|[?$].*\\$$
^[^[]P|]P|(G]|[.])\\$$
\\..$|!|\\|G|^[\\^P]P|P\\^|G.\\$$
...\\^.P|^!|G]\\$$|w|<!|^\\^?P
([^\\\\}<]{3}|][^]]|^).?[$PG]$
^(..[^^].{4,22}\\$|[^?]+\\w)$|2
^(..[^^].{4,22}\\$|[^?]+\\w)$|~
^..(.[!()3G^w]|.{7}$|$)|G\\\\
[[?C(].[-!)|w]|^P|^[^C|\\\\]*$
[?[CP(].[-<)|w]|^P|^[^C|\\\\]*$
^..(.{7}$|.[3Gw!^)]|$)|G.?.?\\)
^...[3w!G)]|^[^\\\\C|]*$|G.?.?\\)
^[^C\\\\|]+$|G.\\)|\\.\\)|w\\^|^P|\\...?]
^P|!.3|w\\^|^[^C\\\\|]+$|\\.[)$-](?!.!)
\\?[^$w]*\\$$|[]C^]\\w$|w.]|\\w.\\)
\\$..\\\\|\\?[^w$]*\\$$|w\\^|[]^C]\\w$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}