$re = '/\d{0,8}d\d{1,8}/';
$str = '2d4+5d10-(42d4-2d100)*34.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);