$re = '/^(75|91|92|93|94)[0-9]{3}$/';
$str = '75001';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);