$re = '/a/';
$str = 'remove spaces in a= element, but not the others. This is my string where a=(1, 2) and b=(3, 4) and c=(5, 6)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);