use strict;
my $str = '<TABLE cellPadding=3 width=100%><td><font class=btime>20:53</font> <a href=news2.php?st=1414691580 target=right>КыргызÑтан: понаÑтроили мечетей.., - Омор Ð Ñ‹Ñбаев</a><br><font class=btime>20:50</font> <a href=news2.php?st=1414691400 target=right>ИÑламÑÐºÐ°Ñ Ð˜Ð·Ð¸Ð´Ð°: как джихадиÑты вынуждают западные компании менÑть названиÑ</a><br><font class=btime>20:48</font> <a href=news2.php?st=1414691280 target=right>Ðе прошло и двух лет. РоÑÑийÑкий летчик Петренко оÑвобожден из плена талибов в ÐфганиÑтане</a><br><font class=btime>19:58</font> <a href=news2.php?st=1414688280 target=right>Игорь Стрелков объÑвил о Ñоздании общеÑтвенного Ð´Ð²Ð¸Ð¶ÐµÐ½Ð¸Ñ "ÐовороÑÑиÑ"</a><br><font class=btime>19:27</font> <a href=news2.php?st=1414686420 target=right>Давление СШРна РоÑÑию будет только нараÑтать. Зачем Путин дал Ñлабину? - Гао ФÑн</a><br><font class=btime>19:21</font> <a href=news2.php?st=1414686060 target=right>Путин не знает Ñтраны, в которой живет. Тайга давным-давно полыхает.., - Ð.Ханымамедов</a><br><font class=btime>19:11</font> <a href=news2.php?st=1414685460 target=right>ПротеÑтующие в Буркина-ФаÑо подожгли парламент, пытаÑÑÑŒ Ñвернуть беÑÑменного (Ñ 1987) президента БлÑза Компаоре</a><br><font class=btime>18:37</font> <a href=news2.php?st=1414683420';
my $regex = qr/\?st=\K\S+(?=\s*target|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}