$re = '/[\p{Pi}\p{Pf}\'"]/';
$str = '“” «» ‘’ \' "';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;