$re = '/^(?!www$)[a-z0-9]+([.-][a-z0-9]+)*$/m';
$str = 'www
words12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);