import re
regex = re.compile(r"(?P<req_ip>^.+)\s+(?P<req_identity>.+?)\s+(?P<req_user>.+?)\s+\[(?P<req_date>.+?)\]\s+\"(?P<req_method>.+?)\s+(?P<req_path>.+?)\s+(?P<req_protocoll>.+?)\"\s+(?P<req_code>.+?)\s+(?P<req_size>.+?)\s+\"(?P<req_referer>.+?)\"\s+\"(?P<req_device>.+?)\"", flags=re.MULTILINE)
test_str = "165.72.105.195 - - [11/May/2021:14:14:14 +0000] \"POST /us/en/registration.html HTTP/1.1\" 500 1676 \"https://my.domain.com/us/en/registration.html\" \"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.44 Safari/537.36 OPR/69.0.3686.7 (Edition beta)\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")