re = /((?=(<\/))(.*?)(?:\>))/
str = '</EventSubType><OrgUnitNm>###</OrgUnitNm></test:CommonAttributes><ProductArrangementBasic><ProductId>####</ProductId></part:Asking>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end